Ticket #1372 (closed defect: fixed)

Opened 6 years ago

Last modified 5 years ago

duplicate emails

Reported by: ian douglas <ian.douglas@…> Owned by: gismo
Priority: normal Component: lists.openmoko.org
Keywords: Cc: freerunner@…

Description (last modified by roh) (diff)

Since your bug submission page seems offline (there's a message about 
bugzilla being imported soon), I decided to forward three copies of the 
same incoming message. I can forward other duplicate copies if you need 
them.

Ian

Attachments

%20OM%20IDE.2.eml (6 bytes) - added by ian douglas 6 years ago.
Added by email2trac
%20OM%20IDE.3.eml (6 bytes) - added by ian douglas 6 years ago.
Added by email2trac
%20OM%20IDE.eml (6 bytes) - added by ian douglas 6 years ago.
Added by email2trac
part0001.ksh (3.4 KB) - added by ian douglas 6 years ago.
Added by email2trac
part0002.ksh (3.4 KB) - added by ian douglas 6 years ago.
Added by email2trac
part0003.ksh (3.4 KB) - added by ian douglas 6 years ago.
Added by email2trac
dupmails.txt (5.6 KB) - added by mmontour 6 years ago.
Pair of duplicate messages (with headers) from the devel list

Change History

Changed 6 years ago by ian douglas

Added by email2trac

comment:1 Changed 6 years ago by ian douglas

  • id set to 1372

This message has 6 attachment(s)

comment:2 Changed 6 years ago by iandouglas

  • Owner set to buglog@…
  • Component set to Bugzilla

Another set of duplicates, separated by a single long line of dash marks:

Return-path: <community-bounces@…>
Envelope-to: ian.douglas@…
Delivery-date: Wed, 07 May 2008 11:14:17 -0700
Received: from mail by server1.wild98.com with spam-scanned (Exim 4.67)

(envelope-from <community-bounces@…>)
id 1Jto9b-0003nl-VY
for ian.douglas@…; Wed, 07 May 2008 11:14:17 -0700

X-Spam-Checker-Version: SpamAssassin? 3.2.3 (2007-08-08) on server1.wild98.com
X-Spam-Level:
X-Spam-Status: No, score=-2.6 required=4.0 tests=BAYES_00 autolearn=ham

version=3.2.3

Received: from sita.openmoko.org ([88.198.124.203])

by server1.wild98.com with esmtps (TLSv1:AES256-SHA:256)
(Exim 4.67)
(envelope-from <community-bounces@…>)
id 1Jto9b-0003ng-6s
for ian.douglas@…; Wed, 07 May 2008 11:14:11 -0700

Received: from localhost ([127.0.0.1] helo=sita.openmoko.org)

by sita.openmoko.org with esmtp (Exim 4.50)
id 1Jto8r-0003eY-61; Wed, 07 May 2008 20:13:25 +0200

Received: from deleuze.hcoop.net ([69.90.123.67] ident=Debian-exim)

by sita.openmoko.org with esmtp (Exim 4.50) id 1Jto8T-0003dY-4Z
for community@…; Wed, 07 May 2008 20:13:12 +0200

Received: from [71.65.238.103] (helo=localhost.localdomain)

by deleuze.hcoop.net with esmtpsa (TLS-1.0:DHE_RSA_AES_256_CBC_SHA1:32)
(Exim 4.63) (envelope-from <clinton@…>)
id 1JtnfI-0006Y6-0V
for community@…; Wed, 07 May 2008 13:42:52 -0400

To: List for Openmoko community discussion <community@…>
References: <cb157dc30805070732y5c010e7bm133b16ae2edf073e@…>
From: Clinton Ebadi <clinton@…>
Date: Wed, 07 May 2008 13:42:34 -0400
In-Reply-To: <cb157dc30805070732y5c010e7bm133b16ae2edf073e@…>

(Oliver Uvman's message of "Wed\, 7 May 2008 16\:32\:20 +0200")

Message-ID: <874p9af1th.fsf@…>
User-Agent: Gnus/5.11 (Gnus v5.11) Emacs/22.1 (gnu/linux)
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Subject: Re: Common Lisp for OM
X-BeenThere?: community@…
X-Mailman-Version: 2.1.5
Precedence: list
Reply-To: List for Openmoko community discussion <community@…>
List-Id: List for Openmoko community discussion <community.lists.openmoko.org>
List-Unsubscribe: <http://lists.openmoko.org/mailman/listinfo/community>,

<mailto:community-request@…>

List-Archive: <http://lists.openmoko.org/pipermail/community>
List-Post: <mailto:community@…>
List-Help: <mailto:community-request@…>
List-Subscribe: <http://lists.openmoko.org/mailman/listinfo/community>,

<mailto:community-request@…>

Sender: community-bounces@…
Errors-To: community-bounces@…

"Oliver Uvman" <oliver.uvman@…> writes:

Jesus! I thought I was the only one wanting to program CL on the OM.
I've had lots of interesting ideas on how to use a gesture-based
interface for writing CL, which could work only thanks to the sparse
syntax, and plan to make that some of the first things I program for
my OM. Hooray!

I'm trying to get McCLIM working with a purely gadget based UI more
nicely right now; CLIM has nice support for adding your own gestures
and input methods so it may be worth checking out if you haven't
already.

See http://www.mikemac.com/mikemac/clim/extended-input.html#22.3 and
22.4 for gestures and the pointer tracking protocol (which would be
used to map between finger gestures and CLIM gestures), and
http://www.mikemac.com/mikemac/clim/silica.html#8.2 for the
documentation on events.

The nice part is that it would not be impossible to automagically make
non-touchscreen-oriented applications work better on a touchscreen
using a custom frame manager and some manipulation of their command
tables.
--

  • jeffcovey becomes too groggy to read the directions and becomes the year's first nasal spray overdose fatality.

_
Openmoko community mailing list
community@…
http://lists.openmoko.org/mailman/listinfo/community


Return-path: <community-bounces@…>
Envelope-to: ian.douglas@…
Delivery-date: Wed, 07 May 2008 11:14:17 -0700
Received: from mail by server1.wild98.com with spam-scanned (Exim 4.67)

(envelope-from <community-bounces@…>)
id 1Jto9b-0003nl-VY
for ian.douglas@…; Wed, 07 May 2008 11:14:17 -0700

X-Spam-Checker-Version: SpamAssassin? 3.2.3 (2007-08-08) on server1.wild98.com
X-Spam-Level:
X-Spam-Status: No, score=-2.6 required=4.0 tests=BAYES_00 autolearn=ham

version=3.2.3

Received: from sita.openmoko.org ([88.198.124.203])

by server1.wild98.com with esmtps (TLSv1:AES256-SHA:256)
(Exim 4.67)
(envelope-from <community-bounces@…>)
id 1Jto9b-0003ng-6s
for ian.douglas@…; Wed, 07 May 2008 11:14:11 -0700

Received: from localhost ([127.0.0.1] helo=sita.openmoko.org)

by sita.openmoko.org with esmtp (Exim 4.50)
id 1Jto8r-0003eY-61; Wed, 07 May 2008 20:13:25 +0200

Received: from deleuze.hcoop.net ([69.90.123.67] ident=Debian-exim)

by sita.openmoko.org with esmtp (Exim 4.50) id 1Jto8T-0003dY-4Z
for community@…; Wed, 07 May 2008 20:13:12 +0200

Received: from [71.65.238.103] (helo=localhost.localdomain)

by deleuze.hcoop.net with esmtpsa (TLS-1.0:DHE_RSA_AES_256_CBC_SHA1:32)
(Exim 4.63) (envelope-from <clinton@…>)
id 1JtnfI-0006Y6-0V
for community@…; Wed, 07 May 2008 13:42:52 -0400

To: List for Openmoko community discussion <community@…>
References: <cb157dc30805070732y5c010e7bm133b16ae2edf073e@…>
From: Clinton Ebadi <clinton@…>
Date: Wed, 07 May 2008 13:42:34 -0400
In-Reply-To: <cb157dc30805070732y5c010e7bm133b16ae2edf073e@…>

(Oliver Uvman's message of "Wed\, 7 May 2008 16\:32\:20 +0200")

Message-ID: <874p9af1th.fsf@…>
User-Agent: Gnus/5.11 (Gnus v5.11) Emacs/22.1 (gnu/linux)
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Subject: Re: Common Lisp for OM
X-BeenThere?: community@…
X-Mailman-Version: 2.1.5
Precedence: list
Reply-To: List for Openmoko community discussion <community@…>
List-Id: List for Openmoko community discussion <community.lists.openmoko.org>
List-Unsubscribe: <http://lists.openmoko.org/mailman/listinfo/community>,

<mailto:community-request@…>

List-Archive: <http://lists.openmoko.org/pipermail/community>
List-Post: <mailto:community@…>
List-Help: <mailto:community-request@…>
List-Subscribe: <http://lists.openmoko.org/mailman/listinfo/community>,

<mailto:community-request@…>

Sender: community-bounces@…
Errors-To: community-bounces@…

"Oliver Uvman" <oliver.uvman@…> writes:

Jesus! I thought I was the only one wanting to program CL on the OM.
I've had lots of interesting ideas on how to use a gesture-based
interface for writing CL, which could work only thanks to the sparse
syntax, and plan to make that some of the first things I program for
my OM. Hooray!

I'm trying to get McCLIM working with a purely gadget based UI more
nicely right now; CLIM has nice support for adding your own gestures
and input methods so it may be worth checking out if you haven't
already.

See http://www.mikemac.com/mikemac/clim/extended-input.html#22.3 and
22.4 for gestures and the pointer tracking protocol (which would be
used to map between finger gestures and CLIM gestures), and
http://www.mikemac.com/mikemac/clim/silica.html#8.2 for the
documentation on events.

The nice part is that it would not be impossible to automagically make
non-touchscreen-oriented applications work better on a touchscreen
using a custom frame manager and some manipulation of their command
tables.
--

  • jeffcovey becomes too groggy to read the directions and becomes the year's first nasal spray overdose fatality.

_
Openmoko community mailing list
community@…
http://lists.openmoko.org/mailman/listinfo/community

comment:3 Changed 6 years ago by iandouglas

  • Owner changed from buglog@… to gismo@…
  • Priority changed from normal to high
  • Component changed from Bugzilla to Lists

adding a bug via Trac auto-assigned it the Bugzilla component

comment:4 Changed 6 years ago by gismo

  • Owner changed from gismo@… to gismo
  • Status changed from new to accepted
  • Description modified (diff)

does this still occur? this this switch I can only encounter single mails going out to your site.

comment:5 Changed 6 years ago by iandouglas

I'm not getting three copies any longer, but I still get two copies on a random frequency.

For example, Michael Shiloh's last Email, subject "Re: Caffeine" sent at 9:52am PST, I only got one copy. The three Emails after that, from Schmidt Andras, Bastian Muck, and Martin "fredthecat", I got two copies of each of their messages.

Other people on the list are reporting the same behavior, including steve@….

I'm debating tracking this by IP address range or country of origin or something, see if there's any correlation.

comment:6 Changed 6 years ago by roh

  • Component changed from Lists to lists.openmoko.org
  • Description modified (diff)

comment:7 Changed 6 years ago by gismo

  • Status changed from accepted to closed
  • Resolution set to fixed

the hosting system was upgraded recently. mailman is now on latest debian stable release.
I checked logs again, but I can not find any multiple mails in outgoing queue.

please report further inconveniences.

comment:8 Changed 6 years ago by roh

  • Priority changed from high to normal
  • Status changed from closed to reopened
  • Resolution fixed deleted

seems to resurface from time to time.. i suspect clamav or spamassassin to be the cause

needs more investigation.

see also / moved from ticket:1699

Changed 6 years ago by mmontour

Pair of duplicate messages (with headers) from the devel list

comment:9 Changed 6 years ago by yarikoptic

confirm that and I am not the only one:
http://lists.openmoko.org/nabble.html#nabble-td682075
I am getting 3-4 copies of some emails. headers don't reveal any reasonable cause

comment:11 Changed 5 years ago by newkirk

  • Cc freerunner@… added

Seems to have been fixed somewhere around 0400 (UTC) on october 23rd.

j

comment:12 Changed 5 years ago by gismo

  • Status changed from reopened to closed
  • Resolution set to fixed

we had some major updates on our front mail gateway (also passing lists.om.org mails).
availability and queue highly improved. close ticket

Note: See TracTickets for help on using tickets.