Ticket #1494 (closed defect: worksforme)

Opened 10 years ago

Last modified 10 years ago

Main Trac keeps logging me out (https issue?)

Reported by: Sjors Owned by: roh
Priority: normal Component: docs.openmoko.org
Keywords: trac login https Cc:

Description

https://docs.openmoko.org/trac/ logs me out whenever I do a search or try to surf directly to a ticket URL. I can create new tickets, but I can not respond to existing tickets because I am logged out whenever I try that.

The problem seems to be that I get kicked from https to http every once in a while. If I change http to https at the right moment (can't really pinpoint this) I stay logged in.

I am running Firefox 3.0.1 on Ubuntu:
Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.1) Gecko/2008072820 Firefox/3.0.1

Change History

comment:1 Changed 10 years ago by roh

  • Status changed from new to accepted

you should be forwarded to ssl as soon as you login.

the only links pointing to http:// and not +s are the logo and the navbar.

if logged in, ssl or not shouldn't make a difference, you are authenticated via session cookie.

when you change your ip (dynip) that obviously means you get logged out.

this is probably a 'worksforme'-canditate.

comment:2 Changed 10 years ago by roh

  • Status changed from accepted to closed
  • Resolution set to worksforme

cannot reproduce this.

please reopen if you are sure that a) session cookies are not blocked and b) your ip does not change.

Note: See TracTickets for help on using tickets.