Ticket #1577 (accepted defect)

Opened 11 years ago

Last modified 10 years ago

SVN Problem - now root of "battery" is missing

Reported by: Manveru Owned by: roh
Priority: highest Component: projects.openmoko.org
Keywords: subversion, svn Cc:

Description

First time I tried to contact: gforge-admin@…
found somewhere on projects.openmoko.org - but it is bounced.

Second time I tried to contact: webmaster@…
which is probably converted to sysadmin@….

Next I wait couple to days to react. Today I have reply from Joachim Steiger, that I should have put my request here. So I am doing it...


I am trying to make initial import to the repository of my project
https://svn.projects.openmoko.org/svnroot/battery but every time I get:

svn: Can't create directory
'/svnroot/battery/db/transactions/0-1.txn': Permission denied

According to what I googled this means something wrong with repository configuration.

Please help.

Change History

comment:1 Changed 11 years ago by gismo

  • Owner set to gismo
  • Priority changed from high to highest
  • Status changed from new to accepted

comment:2 Changed 10 years ago by gismo

  • Owner changed from gismo to Zoup
  • Status changed from accepted to assigned

comment:3 Changed 10 years ago by Zoup

  • Status changed from assigned to closed
  • Resolution set to fixed

same issue as #1532.

comment:4 Changed 10 years ago by Manveru

  • Status changed from closed to reopened
  • Resolution fixed deleted
  • Summary changed from SVN Problem to SVN Problem - now root of "battery" is missing

I still do not have access to SVN of my project, as svn root for this project disappeared. I am reopening as I tread this result of previous fix.

I got following error from my SVN client:

Import C:\Projects\battery-svn to https://svn.projects.openmoko.org/svnroot/battery
Could not open the requested SVN filesystem

comment:5 Changed 10 years ago by Zoup

  • Status changed from reopened to closed
  • Resolution set to fixed

sorry pal, retry now.

comment:6 Changed 10 years ago by Manveru

  • Status changed from closed to reopened
  • Resolution fixed deleted

http://projects.openmoko.org/plugins/scmsvn/viewcvs.php/?root=battery

Returns 404. What am I doing wrong to access SVN on projects?

comment:7 Changed 10 years ago by Zoup

  • Status changed from reopened to closed
  • Resolution set to fixed

hehe, its seems to get an issue isn't it ? :))

please retry,permission issue fixed.

comment:8 Changed 10 years ago by Manveru

  • Status changed from closed to reopened
  • Resolution fixed deleted

I know I am annoying, but still does not work. From SCM browser on page and from my client on PC.

comment:9 Changed 10 years ago by Zoup

You are not my friend, you are not at all.

ill do my best to fix this thing for you, permission have been restored, its possible that this issue caused by our last failed upgrade, can you pleas explain what exactly have you did?

https://projects.openmoko.org/plugins/scmsvn/viewcvs.php/?root=battery is working now.

comment:10 Changed 10 years ago by Manveru

I am trying to do initial import into the repository through TortoiseSVN under Windows to https://svn.projects.openmoko.org/svnroot/battery
But this is always failing with "Could not open requested SVN filesystem".

Trying to access by web applet on project.openmoko.org returns 404. So there is even no empty repository there. I cannot help you more. I you want any logs, to something - just tell me. I can try access SVN from UNIX machine just for test.

comment:11 Changed 10 years ago by Zoup

this is very much unlikely to be client issue, but i have changed permissions again, can you please use simple svn linux package this time?

comment:12 Changed 10 years ago by Manveru

This is what I've just did under Linux:

[manveru@stallman ~/battery]$ svn import --username manveru . https://svn.projects.openmoko.org/svnroot/battery
svn: PROPFIND request failed on '/svnroot/battery'
svn: Could not open the requested SVN filesystem
svn: Your commit message was left in a temporary file:
svn:    'svn-commit.tmp'

So your permission solving do not help with my problem. Please check httpd error.log. It is 19:28 10 Apr 2009 Central European Time now.

This is my other try by svn+ssh:

[manveru@stallman ~/battery]$ svn import  . svn+ssh://manveru@svn.projects.openmoko.org/svnroot/battery
The authenticity of host 'svn.projects.openmoko.org (88.198.93.218)' can't be established.
RSA key fingerprint is ee:62:dc:d6:a7:e5:16:7b:02:bf:4d:ce:a0:d6:26:39.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added 'svn.projects.openmoko.org,88.198.93.218' (RSA) to the list of known hosts.
Permission denied (publickey).
svn: Connection closed unexpectedly
svn: Your commit message was left in a temporary file:
svn:    'svn-commit.tmp'

Yet another try:

[manveru@stallman ~/battery]$ svn import  . svn://manveru@svn.projects.openmoko.org/svnroot/battery
svn: Can't open file '/var/lib/gforge/chroot/svnroot/battery/format': Permission denied
svn: Your commit message was left in a temporary file:
svn:    'svn-commit.2.tmp'

comment:13 Changed 10 years ago by roh

  • Owner changed from Zoup to roh
  • Status changed from reopened to accepted

hm.. somehow the user and groups were wrong, as well as permissions

fixed it i guess...

comment:14 Changed 10 years ago by Manveru

Import C:\Projects\battery-svn to https://svn.projects.openmoko.org/svnroot/battery
Could not open the requested SVN filesystem

So, you are wrong... It is still not working.

comment:15 Changed 10 years ago by roh

hm.. must be a gforge-bug

i set it to 2775

now it looks like this again:

d---rws---   7 scm-gforge scm_battery         4096 Sep  4  2008 battery

should be:

drwxrwsr-x

anybody an idea why gforge fscks up the permissions repeatedly?

Note: See TracTickets for help on using tickets.